Apache添加php7支持

背景由于公司业务需求需要安装禅道项目管理软件https://www.zentao.net/,由于此软件最新版本需要php7以上版本支持,而Apache默认关联php5,所以需要对其进行修改。Apache安装后默认会与自带php-5.4.16版本进行关联,导致禅道安装时自动识别到php5.4.16,安
php 2020年06月10日 164次浏览

php7安装ldap扩展

进入之前编译安装php包中cd~/php7.1.21/ext/ldap/usr/local/php/bin/phpize./configure--with-php-config=/usr/local/php/bin/php-config--with-ldap出错信息:configure:error:
php 2020年06月10日 164次浏览

Composer安装

应开发需求安装Composer,Composer是PHP中用来管理依赖(dependency)关系的工具。可以在自己的项目中声明所依赖的外部工具库(libraries),Composer会帮你安装这些依赖的库文件。1.获取composercurl-sShttps://getcomposer.org/
php 2020年06月10日 159次浏览

PHP安装扩展模块

1、下载源码包进入模块目录下载同版本的php源码包,解压后进入ext目录,此为模块目录。cd/tools/package/php-7.2.8/ext/2、进入需要添加的模块目录这里以gettext为例,进入gettext目录。cdgettext3、指定php-config文件编译安装路径要根据自己的
php 2020年06月10日 176次浏览